BizTalk Server 工具疑难解答

本主题提供了一个集中位置,用于了解使用 BizTalk Server 附带的工具时遇到的常见问题。

已知问题

BizTalk Server 工具和实用工具在支持 UAC 的 Windows 系统上可能无法正常工作

问题

在支持用户帐户控制(UAC)的系统上安装 BizTalk Server 时,BizTalk Server 附带的工具可能无法成功启动,或者可能无法正常运行。

原因

当运行已为特定特权级别标记的应用程序时,如果所需级别高于运行该应用程序的用户,UAC 将显示一个提示,允许你暂时将应用程序特权提升到所需级别。 BizTalk Server 附带的工具没有启用正确的标志来自动请求特权提升,因此该工具将尝试在运行应用程序的用户的当前特权级别运行,并且如果需要更高的特权级别,该工具将失败。

解决方案

若要解决此问题,请使用管理权限运行所有 BizTalk Server 工具。 若要使用管理权限运行工具,请右键单击应用程序,然后选择“ 以管理员身份运行”。

有关用户帐户控制的详细信息,请参阅 https://go.microsoft.com/fwlink/?LinkId=99167

有时 BizTalk 映射器工具箱可能显示为空

问题

有时,当你在 Visual Studio 中打开 Mapper 工具箱时,并不会在工具箱中看到任何功能块。

原因

可能的损坏可能是由于安装/卸载 Visual Studio 插件和/或补丁导致的。

解决方案

若要解决此问题,请执行以下操作:

  1. 关闭 Visual Studio 的所有正在运行的实例。

  2. 以管理员身份启动 Visual Studio 命令提示符

  3. 在命令提示符处,键入以下命令:

    devenv.exe /setup