この記事では、SQL Server の部分的なインストールを削除する手順について説明します。
元の製品バージョン: SQL Server
元の KB 番号: 955404
現象
SQL Server のインスタンスを同じサーバーに初めてインストールできなかった後に再インストールしようとすると、2 回目の試行でもエラーが発生する可能性があります。
原因
この問題は、最初のインストールが失敗した後、部分的にインストールされた SQL Server インスタンスがサーバーに存在するためです。 インストールに失敗した場合、SQL Server セットアップ プログラムはインストールをロールバックしません。 部分的にインストールされたインスタンスには、Enterprise エディション、Standard エディション、Evaluation Edition など、インストールしようとした SQL Server のエディションは含まれません。 同じバージョンを同じサーバーにインストールしようとすると、セットアップ プログラムによって既存のインスタンスが検索されます。 ただし、セットアップ プログラムでは、インストールする SQL Server のバージョンを特定できません。 そのため、インストールは失敗します。
解決方法
次の手順に従って問題を解決します。
システム上の各 SQL インスタンスのデータベースの有効なバックアップがあることを確認します。
Summary.Txt ファイル セットアップ ログ ファイルに移動し、セットアップ プログラムによって提案された setup コマンドをメモします。
管理者特権でのコマンド プロンプトを使用して、インストール メディア ディレクトリにアップグレードする <SQL バージョンの "setup.exe" の場所に移動し> 手順 2. からコマンドを実行します。
注
適切なインスタンスに対してコマンドを実行しているか、作業インスタンスをアンインストールする可能性があることを確認することが非常に重要です。
インストール センター ウィザード GUI を SQL Server プログラム グループから起動するか、セットアップ プログラムを再実行します。[ツール] メニューに移動し、インストールされている SQL Server 機能検出レポートを選択し、レポートに
<instance name>.INACTIVE
インスタンスが表示されていないことを確認します。検出レポートに非アクティブなインスタンスがある場合は、次の手順に従って削除します。
対応する XML ファイルを開きます。
各
MSSQLSERVER.INACTIVE
エントリを検索します。ProductCode
の値を見つけてメモします。 次に例を示します。ProductCode="{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}"
管理者として コマンド プロンプト を開き、
ProductCode
ごとに次のコマンドを実行します。msiexec /x {PRODUCT-CODE-GUID}
注
非アクティブなインスタンスにリンクされている ProductCode ごとにコマンドを繰り返します。 次に例を示します。
msiexec /x {9FFAE13C-6160-4DD0-A67A-DAC5994F81BD}
最初に完了できなかったセットアップ プログラムを再試行してください。
注
上記の手順の後も検出レポートに非アクティブなインスタンスが表示される場合は、「 失敗した SQL 2005、2008、R2、または 2012 Install/Upgrade - MSSQLSERVER を修正する方法」に記載されている手順を使用します。INACTIVE システム上の SQL Server の部分的なインストールを修正します。