このトピックでは、BizTalk Server に含まれるツールの使用中に発生する一般的な問題に関する情報を一元的に提供します。
既知の問題
UAC をサポートする Windows システムで BizTalk Server のツールとユーティリティが正しく機能しない
問題
BizTalk Server がユーザー アカウント制御 (UAC) をサポートするシステムにインストールされている場合、BizTalk Server に含まれるツールが正常に起動しないか、正しく機能しない可能性があります。
原因
特定の特権レベルのフラグが設定されたアプリケーションを実行するときに、必要なレベルがアプリケーションを実行しているユーザーのレベルより高い場合は、UAC によってプロンプトが表示され、アプリケーション特権を必要なレベルに一時的に昇格できます。 BizTalk Server に付属のツールでは、特権の昇格を自動的に要求するための適切なフラグが有効になっていないため、ツールはアプリケーションを実行しているユーザーの現在の特権レベルで実行を試み、より高い特権レベルが必要な場合は失敗します。
解決策
この問題を解決するには、すべての BizTalk Server ツールを管理特権で実行します。 管理者特権でツールを実行するには、アプリケーションを右クリックし、[ 管理者として実行] を選択します。
ユーザー アカウント制御の詳細については、「 https://go.microsoft.com/fwlink/?LinkId=99167」を参照してください。
BizTalk マッパー ツールボックスが空に表示されることがあります
問題
Visual Studio でマッパー ツールボックスを開くと、ツールボックスに Functoid が表示されないことがあります。
原因
Visual Studio アドインや patch(es) のインストール/アンインストールによって破損する可能性があります。
解決策
これを解決するには、次の手順に従います。
Visual Studio の実行中のすべてのインスタンスを閉じます。
管理者として Visual Studio コマンド プロンプトを起動します。
コマンド プロンプトで、以下のコマンドを入力します。
devenv.exe /setup